Tuesday, March 26, 2019


Rip configuration in cisco packet tracer

The Routing Information Protocol (RIP) sends routing-update messages at regular intervals and when the network topology changes. When a device receives a RIP routing update that includes changes to an entry, the deice updates its routing table to reflect the new route. After updating its routing table, the device immediately begins transmitting RIP routing updates to inform other network devices of the change.






Procedure:

  • now drag and drop switches and pcs into the work space
  • connect switches and pcs using copper straight wires in the fast Ethernet ports.
  • provide pc with IP address and gateway to the pcs.

add IP address to the pc by double clicking on the pc and going to IP configuration mode.





  • connect routers and switches using Gigabit port

Configuration of routers: Router 1:

Router(config-if)#exit

Router(config)#interface Serial0/1/1

Router(config-if)#ip address 10.10.10.20 255.0.0.0

Router(config-if)#ip address 10.10.10.20 255.0.0.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface Serial0/1/1, changed state to up



%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/1, changed state to up.
similarly for router 2 has to be done.





CONFIGURATION OF RIP USING CLI IN CISCO PACKET TRACER:

·                                             after the implementation above routing config.go to CLI.

·                                             Type no ip route network_ip network_subnet gateway_router_address.

·                                             router rip and hit enter.

·                                             Type network address subnet etc

·                                             As shown below:





Similary for 2nd router has to be done.

Result:

The RIP is configured.



Implementation of network address translation in cisco packet tracer

 Network address translation (NAT) is a method of remapping one IP address space into another by modifying network address information in the ip header of packets while they are in transit across a traffic routing device. The technique was originally used as a shortcut to avoid the need to readdress every host when a network was moved. It has become a popular and essential tool in conserving global address space in the face of IPv4 address exhaustion. One Internet-routable IP address of a NAT gateway can be used for an entire private network.




Fig1



Types of NAT:

Static NAT: In this, a single private IP address is mapped with single Public IP address, i.e., a private IP address is translated to a public IP address. It is used in Web hosting.

Dynamic NAT: In this type of NAT, multiple private IP address are mapped to a pool of public IP address. It is used when we know the number of fixed users wants to access the Internet at a given point of time.

Procedure:

1.      Drag and drop the network devices to create the above topology using interfaces.

2.      Assign IP Address to the devices as follows:

a.       PC0:  10.0.0.10

b.      PC1:   10.0.0.20

c.       PC3:   10.0.0.30

d.      ROUTER 0 SE 0/1/0 100.0.0.1

e.       ROUTER 0 GIG0/1   10.0.0.1

f.        ROUTER 1 SE0/1/0 100.0.0.2

g.      ROUTER 1 GIG0/1   192.168.1.1

h.      SERVER 0  192.168.1.10

3.      Assign network address to the Router in cli as follows:

·         Router 1:

Router#en

Router#config t

Router(config)#interface Gig0/0

Router(config-if)#ip address 10.0.0.1 255.0.0.0

Router(config-if)#no shutdown

Router(config-if)#exit

Router(config)#interface set0/1/0
Router(config-if)#ip address 100.0.0.2 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit



  

   Router 2:

Router#configure terminal
Router(config)#interface gig0/1
Router(config-if)#ip address 192.168.1.1 255.255.255.0
ROUTER(config-if)#no shutdown
ROUTER(config-if)#exit
ROUTER(config)#interface Set0/1/0
ROUTER(config-if)#ip address 100.0.0.2 255.0.0.0
ROUTER(config-if)#no shutdown
ROUTER(config-if)#exit

4. Configure Static NAT:


Static NAT configuration requires three steps: -

  • Define IP address mapping
  • Define inside local interface
  • Define inside global interface
  • Syntax:

Router(config)#ip nat inside source static [inside local ip address] [inside global IP address]

Router 1 NAT configuration:



Result:

Testing Static NAT Configuration:

Type following command in the command prompt.



Router#show ip nat translations

Pro Inside global Inside local Outside local Outside global

--- 50.0.0.10 10.0.0.10 --- ---

--- 50.0.0.20 10.0.0.20 --- ---

--- 50.0.0.30 10.0.0.30 --- ---






 
 
 






Tuesday, March 5, 2019


Implementation of DHCP in cisco packet tracer

Dynamic Host Configuration Protocol (DHCP) is an application layer protocol used to distribute various network configuration parameters to devices on a TCP/IP network. – IP addresses, subnet masks, default gateways, DNS servers, etc

Procedure:

1.      Create the above topology shown using the cisco packet tracer work space.

2.      Assign IP address to the gig interface as following:




3.      A Cisco router can be configured as a DHCP server. Here are the steps:

·         Exclude IP addresses from being assigned by DHCP by using the ip dhcp excluded-address FIRST_IP LAST_IP

·         Create a new DHCP pool with the ip dhcp pool NAME command.

·         Define a subnet that will be used to assign IP addresses to hosts with the network SUBNET SUBNET_MASK command.

·         Define the default gateway with the default-router IP command.

·         Define the DNS server with the dns-server IP address command.

·         (Optional) Define the DNS domain name by using the ip domain-name NAME command.

·         (Optional) Define the lease duration by using the lease DAYS HOURS MINUTES command. If you don’t specify this argument, the default lease time of 24 hours will be used.

 

Router(config-if)#ip dhcp pool IP01
Router(dhcp-config)#net 192.168.100.0 255.255.255.0
Router(dhcp-config)#exit
Router(config)#ip dhcp exec 192.168.100.1 192.168.100.15
^
% Invalid input detected at '^' marker.
Router(config)#ip dhcp exc 192.168.100.1 192.168.100.1
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console



4.      Now click on the generic pc 0 , go to IP configuration and select DHCP.

 Result:

DHCP server has been implemented:



OSPF protocol configuration in cisco packet tracer
The OSPF (Open Shortest Path First) protocol is one of a family of IP Routing protocols, and is an Interior Gateway Protocol (IGP) for the Internet, used to distribute IP routing information throughout a single Autonomous System (AS) in an IP network.


Fig 1:Ospf config

Procedure:
1.      Define the following topology in cisco packet tracer.
2.      Assign IP addresses to the network devices:
      3 . configure router interfaces and switch ports:

For router 0:
Router(config)#int gig 0/1
Router(config-if)#ip add 10.0.0.2 255.0.0.0
Router(config-if)#no shut
Router(config)#interface Serial0/1/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Similarly for router 2 as per the given iage below.
Opsf configuration step:
To configure OSPF routing protocol on the above-mentioned topology, you need to perform the following steps.
Router(config)#router ospf <process id 1-65535>
Router(config-router)network <network address> <wild card mask> area <0-4294967295>
1.    Move on to Router1 and execute the following commands to specify the OSPF network and area.
2.    Router1(config)#router ospf 200
3.    Router1(config-router)#network 10.0.0.0 0.255.255.255 area 0
4.    Router1(config-router)#network 192.168.1.0 0.0.0.255 area 0.0.0.0
Router1(config-router)#exit
 Similary for router 2 has to be done .